LineageOS on Moto X4 (payton)

Aus Cactus Howto
Wechseln zu: Navigation, Suche

docs

limitations

  • OTA updates (i.e. standard "nightly" updates) cannot be applied via network download but have to be downladed via adb/usb
  • NetFlix app cannot be used in LineageOS

prepare

Using MacOS here

install

oem unlocking

for oem unlock of payton: use instructions on https://www.getdroidtips.com/unlock-bootloader-moto-x4/

  • get unlock key from Motorola - output from "fastboot oem get_unlock_data" cannot be used directly to unlock phone
  • make sure to use Chrome-Browser for getting the unlock key at Motorola!!! Otherwise the "get unlock code" button will not be visible.
macantha:~ tim$ fastboot oem unlock
(bootloader) Check 'OEM unlocking' in Android Settings > Developer 
(bootloader) Options
OKAY [  0.001s]
Finished. Total time: 0.001s
macantha:~ tim$ 
  • activate oem unlocking in android settings
  • execute twice:
fastboot oem unlock xxxxxxxxxxxxxxxxxxxx (20 digits)
  • reboot

install via twrp recovery

  • NOTE: Monthly security updates may break decryption of /data in TWRP. MTP does not work at this time, but you can use adb to transfer files.
  • make sure to install the .img (not the .zip) file of the TWRP recovery image:
fastboot boot twrp-3.2.3-1-payton.img
  • wipe
  • format data partition to remove encryption
  • wipe advanced - system partition
  • copy image to sdcard:
adb push lineage-15.1-20181030-nightly-payton-signed.zip /sdcard/
  • install image in twrp (select above image)
  • Once installation has finished, return to the main menu, tap Reboot, and then System.
  • ignore any messages "no os installed"
  • IMPORTANT: for this phone do not install any Updates via WiFi as this will hard brick your Moto X4!
  • In case you did not read the above - read on in the next section ;-)

restore in case of hard brick

  • all attemps so far using twrp have led to hard bricked phone
  • symptoms: blank screen, no led, pressing of power button does not seem to do anything (even long pressing of >20 secs)

make fastboot mode work again

all of this needs to be done via Windows PC. (in my case Win10), disabled anti-virus SW

C:\Users\User\Downloads\blankflash>blank-flash.bat

C:\Users\User\Downloads\blankflash>.\qboot.exe blank-flash
Motorola qboot utility version 3.86
[ -0.000] Opening device: \\.\COM3
[  0.001] Detecting device
[  0.004] ...cpu.id  = 172 (0xac)
...
[  4.453] Rebooting to fastboot
[  4.458] Total time: 4.459s

C:\Users\User\Downloads\blankflash>pause
Drücken Sie eine beliebige Taste . . .

C:\Users\User\Downloads\blankflash>
  • will come up in fastboot mode.

wipe device

  • use twrp as shown above to wipe and format partions then switch to fastboot mode again

re-installing stock oreo image

chmod 755 osx-fastboot 
mv osx-fastboot /Users/tim/bin
  • enter fastboot mode on moto x4 and execute the following commands on your mac
osx-fastboot flash partition gpt.bin
osx-fastboot flash bootloader bootloader.img
osx-fastboot flash modem NON-HLOS.bin
osx-fastboot flash fsg fsg.mbn
osx-fastboot erase modemst1
osx-fastboot erase modemst2 
osx-fastboot flash bluetooth BTFM.bin
osx-fastboot flash dsp dspso.bin
osx-fastboot flash logo logo.bin
osx-fastboot flash boot boot.img
osx-fastboot flash system system.img_sparsechunk.0
osx-fastboot flash system system.img_sparsechunk.1
osx-fastboot flash system system.img_sparsechunk.2
osx-fastboot flash system system.img_sparsechunk.3
osx-fastboot flash system system.img_sparsechunk.4
osx-fastboot flash system system.img_sparsechunk.5
osx-fastboot flash system system.img_sparsechunk.6
osx-fastboot flash system system.img_sparsechunk.7
osx-fastboot flash system_b system_other.img
osx-fastboot flash oem oem.img
osx-fastboot erase carrier
osx-fastboot erase userdata
osx-fastboot erase ddr
osx-fastboot reboot

possible next steps